I’m just curious about which is the most efficient way of doing this kind of node enumiration:

for i in something():
    o=[var1,var2,var3,varN][i]
    o.new()
    o.do_something_based_on_number_of_loops()
    add_child(o)

or

for i in something():
    match i:
        0:
            o=var1
            o.new()
            o.do_something_based_on_number_of_loops()
            add_child(o)
        1:
            o=var2
            o.new()
            o.do_something_based_on_number_of_loops()
            add_child(o)
        2:
            o=var3
            o.new()
            o.do_something_based_on_number_of_loops()
            add_child(o)
        N-1:
            o=varN
            o.new()
            o.do_something_based_on_number_of_loops()
            add_child(o)

or

var items = [var1,var2,var3,varN]
for i in something():
    o=items[i]
    o.new()
    o.do_something_based_on_number_of_loops()
    add_child(o)

Or is there a more efficient way of doing it?

Edit: Sorry if that wasn’t clear. Is it better to constantly get something from an “unstored list”, store the list in a variable, or not use a list and use a match statement instead? Do they have any advantages/disadvantages that make them better in certain situations?

  • @Rodeo@lemmy.ca
    link
    fedilink
    2
    edit-2
    9 months ago
    func _show_only_first_layer_dots():
        for c in $Layers.get_children():
            c.get_node("Dots").visible = false
        $Layers.get_child(0).get_node("Dots").visible = true
    

    Mines 10x more readable and I saved a line of code.

    Simplicity is king.

    • @tabular@lemmy.world
      link
      fedilink
      English
      0
      edit-2
      9 months ago

      If you’re working on the function then yes; everyone learns for loops fairly early on.

      If you just need to know what it is intended to do then I would argue you didn’t need to read anymore than the function name. If you do look further then I’d argue just the name of the helper function was easier to read than the whole for loop.

      • @Rodeo@lemmy.ca
        link
        fedilink
        19 months ago

        It’s a poor name choice then, because it actually says less about what it’s doing than the main function does.

        Besides, what is the point of “looking further” just to stop at another function name? Wouldn’t looking further imply the need to review the implementation?

        • @tabular@lemmy.world
          link
          fedilink
          English
          19 months ago

          In practice it turns out the method to make just the first element visible was redundant anyway. It would be made visible during the setup function that all elements call.

        • @tabular@lemmy.world
          link
          fedilink
          English
          19 months ago

          Seeing another function divides the code into another subsection. In the example it’s the only one there but if more was added then you could choose where to focus your attention on the implementation.